Jump to content
PayPal donations: [email protected] ×

Latitude E7450 open core Big Sur installation help


Recommended Posts

  • Administrators

in the link it says you can do it in a dos enviroment.

1. Go into the DOSsub-directory.
2. Insert a blank CD-R disc into your CD/DVD R/W drive.
3. Burn the ISO image into a CD-R media.
4. Insert the CD-R (created from the above steps) into the CD-ROM/DVD drive in the target system.
5. Boot your system from the CD/DVD drive (for instructions, please refer to the manual that came with your system).
6. Please select the targeted drive once your system boots into DOS.
7. The next screen is a warning message. It states the risks and reminds user to backup important files before proceeding. Please click "Y" to proceed.
8. Firmware upgrade will proceed. When the firmware upgrade process completes, the user will be prompted to reboot the machine. Remove the CD-R from your CD/DVD drive, and reboot your system. It will boot into Windows.
9. To confirm the firmware update was successful, open Device manager -> open SSD -> click Properties -> choose hardware ID under Details and check the firmware version.

Link to comment
Share on other sites

  • Replies 29
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

Damn, that’s a hell of a job... and I don’t have a cd write  drive, but also the latitude e7450 doesn’t have a cd/dvd drive. So that’s not an option.

could the problem be something else? It had clover/catalina on it and that worked perfect.

I guessed opencore/big sur was going to be easy, but was I wrong... ☹️

Link to comment
Share on other sites

  • Administrators

CPU model is of no influence here, except if you made use of a CPU-specific power management SSDT. But that's not the case in the pack posted by JakeLo where the generic SSDT-PLUG is provided instead.


Post your full hardware specs, including model of wireless card. You may want to reset your BIOS to default and set it up again to be on the safe side of things. Thereafter, the 2 x essential settings are UEFI BIOS mode and disk in AHCI mode. Refer to this thread for guidance.

Link to comment
Share on other sites

Okay, took a while to reply, but I tried it again. Put in a new SSD to be sure. Computer installs without problems. I mount the EFI's from the installer and the SSD and transfer the EFI folder from the USB installer to the EFI drive from the SSD. The I restart the computer and the problem starts all over again:

'it boots the MacHD, then reboots halfway. I get the Dell logo, it tries to boot MacHD and then it will give me that warning thing 'You need to restart you computer. Hold down the power button etc.'. And that goes on into a loop for multiple times until the machine shuts off.'

I tried Reset NVRam, tried creating a new boot option in the BIOS, point it to /efi/oc/opencore.efi, doesn't work. If I put in the USB installer the machine is able to boot from the USB.


I've attached some screenshots, hope anyone can help me out.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...