Jump to content
PayPal donations: [email protected] ×

Sierra 10.12.6 on Dell XPS L502x - Audio ALC665 and other issues

Bloody Raven

Recommended Posts

Hi All,

Having followed several guides and trials, I'm still unable to make Sierra in my laptop L502x work smooth. 

Of all the issues not getting the audio to work bugs me a lot. My audio is Realtek ALC665. 

First of all it is tedious to make the codec id visible in DPCI or system report under "about this mac". As last resort I tried VoodooHDA which detected the codec. I've attached the screenshots and also in Imgur


I've tried these methods so far -

1. AppleALC with Lilu. Followed u/corpnewt guide twice. 

2. CloverHDA by insanelyDeepak.

3. AppleHDA from insanelyMac - https://www.insanelymac.com/forum/files/file/24-applehda-for-alc665/

4. AppleALC665 from one of the posts here - https://osxlatitude.com/forums/topic/7809-dell-xps-15-l501x-nvidia-gt-435m-yosemite-complete/


In all I tried different layout to no effect.  First 2 methods say id must be 12 or 13. Third says 88. Fourth 76.  Sometimes the system had 7 when I entered 13. 

I installed the kexts in S/L/E or kexts/other. Both didn't work. Right now I'm more confused than I started.

Does anyone have a working solution?


Things that don't work -

Audio, integrated webcam, logitech webcam c270, synaptic trackpad gestures(Used emlyDinesh 4.7beta 5 kext and pane script from hackintosherzone), USB eSATA port from NEC. 


Not yet tried -

Fn keys for brightness control, battery icon in menubar, iMessage/facetime. 


I've also patched DSDT using Rehabman guide from tonycrapx86. Laptop backlight control and disabling NVidia optimus in SSDT(not so sure if disabling works). 


Could anyone please help me? Thank you!


Laptop config

Model - Dell XPS 15 L502x(2011 Sandy Bridge)

CPU - i3-2310M. RAM - 4GB

Mobo - H67, Intel 6 series chipset. 

Audio - Realtek ALC665

Graphics - Intel HD3000(1366x768) and Nvidia optimus GT 525M.



Problem reporting files(google drive link)

Screen Shot 2018-09-09 at 17.15.16.png

Screen Shot 2018-09-09 at 17.15.28.png

Edited by Bloody Raven
Added links
Link to comment
Share on other sites

Thank you, Jake! You made many things work. 


List of things that work -

Trackpad, Webcameras(Integrated and logitech c270), battery detection and icon.

Bluetooth detected but turning off is greyed out. A quick search says I need to disable in boot args?


Not working - 

Audio - detected in system report with id 7. In the DSDT I see that you didn't add layout id under HDEF. What value/change should be added? I still don't see devices in the sound/output under system preferences.

USB 3.0 eSATA works but the other 2 ports don't. My usb mouse turns on but I can't use it.


Other issues -

Also I see graphic glitches(red horizontal line flashing) across the screen. 

In VLC I can't fast forward, rewind or skip to next video file. VLC hangs. Every time I need to force quit. 

Similar issues in Safari youtube videos -- Can't skip forward. After that no playback. In Chrome it works fine for now. 

Just as I tested out those problems, the system hung. Only my mouse was responsive. Had to hard reset. 


Could you please help me further? 


problem reporting files(google drive link)




Screen Shot 2018-09-09 at 23.53.29.png


Screen Shot 2018-09-09 at 23.54.15.png

Screen Shot 2018-09-10 at 00.46.44.png

Screen Shot 2018-09-09 at 23.54.01.png

Edited by Bloody Raven
Wrong screenshot and added one more
Link to comment
Share on other sites

  • Moderators

The occasional glitch is known, you can add additional 4 gb ram which might alleviate some of the glitches.

I remove the layout-id in DSDT, but added in Config. Currently set to 13, you could try switching to 12 to see if it'll work.

There's no real support to NEC USB 3.0, so you're kinda stuff with it. The last supported OS X of GenericUSBXHCI for NEC was Mavericks or Yosemite I think.



Link to comment
Share on other sites

Thanks Jake. 


Video problems in VLC and Safari also RAM related? I face same problems even with audio tracks in VLC. 


14 hours ago, Jake Lo said:

I remove the layout-id in DSDT, but added in Config. Currently set to 13, you could try switching to 12 to see if it'll work.

Unfortunately none of the ids I provide work. Since AppleALC is provided by the same author as CloverHDA,  I added those kext patches to config. Still nothing. The HDEF in  ioReg layout id is at 07 00 00 00 regardless of the change I make(see screenshot). In here and here, it was mentioned adding IRQ and HPET fixes might fix the audio. So tried it in DSDT and in patched folder, I use that patched version.  No change. What to do now? 


I tested trackpad. SIngle tap works but other gestures don't. Is this the limit of voodooPS2controller kext? 

Since the other 2 USB ports weren't working, I retraced the steps. I removed USBXHCI_FL1009.kext. Now all the 3 ports work but not always. 


USBinjectAll kext enables webcameras and also bluetooth. Do you know a way to disable bluetooth? 


To enable brightness adjustment through the keyboard, if I follow this guide, will I be successful? 



Screen Shot 2018-09-10 at 21.17.22.png


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...