Jump to content
PayPal donations: [email protected] ×

High Sierra post install help with Dell XPS (L502x)


Recommended Posts


I've install High Sierra (fresh install on new SSD) using Clover and I've got it booting and running fine from the SSD.   Most functionality is working fine with the various kexts, patches and settings I've been able to find, but as expected there are still a couple of post install issues I need some help with. 




- Audio

  • no device found by OS in System Report
  • device is RealTek ALC665


- ShutDown

  • laptop will not power down with the shutdown command is issued.  The shutdown command tears down the OS, but fails to power off the laptop.


- function keys 

  • most important to me:  Brightness controls and Volume controls
  • on this device I'd like them mapped to the default keyboard combinatons
    • Brightness Down = Fn+F4
    • Brightness Up = Fn+F5
    • Volume Down = Fn+F11
    • Volume Up = Fn+F12


- USB3

  • device has NEC/Renesas USB3.0 host controller
  • I understand from my readings that the NEC controller may not be supported in 10.12 and later, so may need to live with this. This is disappointing however as I use the  built in eSATA/USB3.0 port to plug in my external backup drive.
    • I had this device function fine with my Yosemite build using Clover.  Any option for reusing the old kexts, setting, etc?


I've attached the debug files as requested as well as a few screen shots.


Any and all help is appreciated.









no-Audio .png





Link to comment
Share on other sites

  • Moderators

For audio, if it truly is ALC665, you have 2 options in AppleALC.kext, layout-id 12 or 13. Remove AppleHDA275.kext, restore a vanilla AppleHDA in /S/L/E if you had removed it.

For shutdown, try enable FixShutdown and Halt Enabler. If still fails, I noticed that your Nvidia is still loading. You need to disable it completely. Try adding this to ACPI/Patched

For keyboard Fn keys, try Karabiner-Elements app to reset the keys. See example here


Link to comment
Share on other sites

Gave up on trying to make audio work using AppleALC. I tried all of the various layout id's and suggestions above but couldn't get it working, ...so I just went with VoodooHDA.   Audio now works.


Next problem is display brightness, which I have no control over.  In fact the slider bar doesn't even show up in Sys/Preference/Displays.   What do I need to make this work?






Shutdown/Restart are still not working properly after trying your suggestions above..  Any help you can provide here .



Thanks in advance for all you do and the help you provide this communitiy.


Link to comment
Share on other sites

Thanks JakeLo...adding the "right" kext and new .aml file did the trick for brightness control.  They are now working.


The last item that is still problematic is Shutdown and Restart....they don't work properly.


Any help you can provide is appreciated.


Do I need a new debug file?   The one in post #3 would have everything except the AppleBacklightFixup kext

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...