Jump to content
PayPal donations: [email protected] ×

Can't generate SSDT.aml


Recommended Posts


First much gratitude to Jake Lo and Radionoise. I also have a Inspiron 5558 and most things came together today.


Specs are: working...

i5 5200 Broadwell

Intel HD 5500

Realtek HD Audio





Intel 7260 wifi and Bluetooth not working using an asus n10 usb dongle for now.

Realtek card reader not working

(I'll order a new wifi card tomorrow)


Issues are as follows, I couldn't generate SSDT.aml, ssdtPRGen.sh fails with an error of "unknown processor model"

I suspect that's why I can't log into face time?

Clover appeared to be installing fine but nothing showed up in EFI folder, just copied in from the USB


Link to comment
Share on other sites

  • Administrators

SSDT generation is for CPU power management; nothing to do with FaceTime which requires an Ethernet card/interface declared as 1st interface en0. Sometimes the wireless card gets in there 1st and Ethernet is en1. In that case, you need to delete all network interfaces from your Network PrefPane and all plist files from /Library/Preferences/SystemConfiguration.


If your CPU is not recognised by the script (because it may not be present in the default tool database), just can try adding the characteristics of your CPU manually with the script optional parameters. All are indicated at Pike R Alpha's repo linked above.

Link to comment
Share on other sites

Wow, thanks.

Sorry I took so long, I was doing a second 5558 that has the i5 5250. The beta version worked perfect for both. Had a little trouble with the second laptop's hard drive. For some reason couldn't change partitions any way I tried. Eventually did a wipe sector by sector. Working fine now.

Only issues left are the FaceTime and imessage but since you say they can be related to networking perhaps they will fix themselves once I get the proper wifi card.

Thanks again, I have tried this a couple times in the last say 5 years or so but never got anything stable. This works great. Stable. Still kept my existing Windows setup and dual booting.

Link to comment
Share on other sites

Haha, not a word of a lie. I followed all those instructions on that page. I always make sure I copy paste commands. Rebooted and my apps folder was empty, no apps would start and missing most of my right click menu....

too funny.

At least I'm getting fast at reinstall, haha


On another note I see your internet device is supposed to be device 0, I had been going off the assumption that Ethernet was supposed to be device En0

Since I'm using a USB dongle for wifi I'll probably have to wait until my DW1560 arrives. No rush.


I had the terminal window open prior to copy pasting those commands, I never looked at them, just copy pasted. I wonder if I wasn't in the wrong folder and that may have caused that, No matter. I can still follow the first half of that tutorial you linked to and see. But after I get the new wifi card.

Link to comment
Share on other sites

Oh no. Not at all. I'm really happy. It's nothing, I went back and had a look. It has the commands to set the directory. It was in the first part.

It must have exposed a flaw I had somewhere earlier in the setup. It's been great. Everything working as it should. Just a quick re-install.

Anyways I've run out of time for now, got to take off for work for a few weeks.

I've learned so much this past week about Macs and dual booting them with Windows. Got a great site here.

I'll start again in a couple weeks from scratch, catch my flaw somewhere. Do a time machine backup before I hit that guide.

Thanks so much for all your time so far.

Enjoying El Capitan. in fact the GF is having me help her do a clean install on her MacBook pro. Apparently she has been wanting to upgrade to El Capitan for some time and also wanting to clean install so she is building a couple clean USB sticks for her legit MacBook.

Lots of good positive things.


Thanks again. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...