Jump to content
PayPal donations: [email protected] ×

D630 Nvidia - Mavericks using Clover - almost working perfectly


Recommended Posts

Dear Forum,


I need to install Mavericks or Yosemite on my laptop in order to use an usb audio box called VRM-BOX from Focusrite (support stopped). I decided to give Mavericks a try and, because I like to take some risks, I decided to install it using the last version of Clover (Clover_v2.4k_r4114). 


I first copied the Mavericks installation image to an usb drive using terminal command (formatted using MBR). 

Then I installed Clover on the usb drive and copied the dsdt.aml, HFSPlus.efi, and all the kexts present on this site for my model to the appropriate folders of the usb drive.

The Clover settings are : "Bootlaoder (boot0af)" - "CloverEFI 64 - bits SATA" - "Driver64 UEFI (OsxAptioFix2Drv-64 - CSMVideoDxe-64 - PartitionDxe-64)"


I inserted the usb drive inside the D630, started the machine and changed the bios settings according recommandations.

After restart I pressed the F12 key to bring the boot menu and selected the usb drive. 

Clover's boot loader appeared and I selected the first option (Maverick Installation).

It took around 45 minutes to complete and, after restart, I reached the Welcome window.

After another restart I installed clover on the system disk and (after reboot) I was able to start the system using clover via the system disk (around 35 sec to boot).


Everything was perfect until I installed the VRM-BOX driver and made some test. If the device is off (no room effect), the audio is played correctly (although with a little bit of distortion). If the device is switched on, audio is hatched, with long gaps of silence.


I verified the cpu charge, it is not overloading. I tried a different usb port, but it is the same result.

Could it be related to a lack of power available on usb ports? 

Could it be solved by installing E.D.P. or another kext?

What about config.plist? I still have the original one, I have not found a proper one for my system. Could it help to change it?

Should I try myhack?


Thanks for watching. 

Link to comment
Share on other sites

  • Administrators

More likely, something to do with inadequate settings of Clover re: system's fine-tuning. You may not have proper CPU SpeedStep working.  Why choose Clover over myHack ? Fully-tuned bootpacks (for myHack installations) are available here. Make sure to set your BIOS parameters properly too. Full details here.


NB: T7250 is a low-spec FSB800 Meron CPU (2.0Ghz, 2Mb L2 cache). The small L2 cache contributes a lot towards low performance. I've compared D630's overall performance under OS X with a T7500 and a T9300 and the difference is quite significant...

Link to comment
Share on other sites

Thanks for the answer.


I verified the bios settings. Fast boot was not on "Minimal" (set), but the rest was ok. 


I have installed E.D.P. on it and, after a few restart, it is now working, no more hatching when using vrm-box.

But, I have to use a mouse (trackpad is very slow), it is taking 4 minutes to boot, so I'll reinstall using Myhack.


I did it mainly because Clover allows vanilla installation, Myhack is modifying /S/L/Extensions.


Have a nice Sunday.

Link to comment
Share on other sites

  • Administrators


Clover allows vanilla installation, Myhack is modifying /S/L/Extensions.


That's incorrect; MyHack allows full vanilla installations too and does not "modify" /S/L/E per sé. It adds a kext called myHack.kext where all add-on kexts present in /E/E are injected as PlugIns with their individual version increased to 1111. That way, there can be no clash with any vanilla kext which all remain untouched.


You can stick with Clover of course but make sure you tune its config.plist for the D630. All kexts posted in my D620/D630 bootpacks can be used with Clover of course.

Link to comment
Share on other sites

So what I said is correct, it does modify the /S/L/Extensions, even if the modification is not applied on an Apple kexts. It does removes up to tree Apple kexts from /S/L/E after installation and it merge kext from /Extra to /S/L/E when running myFix... 


Anyway, it took me FIVE hours only to transfer the system from the usb installation key to the disk using Myhack (It took 30 minutes to do it with Clover).

Then, I was not able to start the system without using the "-f" flag (stuck on "missing bluetooth controller", it is a graphical problem).

I tried "-v", "GraphicsEnabler=no" (or "yes"), nv_disable=1, still stuck at the same level.


After running "myFix - FULL" and restarting, the problem was not solved, I still have to use the "-f" flag.


Thanks for the help you offer me but I don't know how to reach your bootpacks. I checked your profile page but I didn't found them there.  

Hellas I don't know how to tune a config.plist for my machine, it could take some time if I have to do it from scratch.

I see that you have the same machine as mine in your list, don't you use clover on it? Don't you have a config.plist that I could use?



Link to comment
Share on other sites

  • Administrators

You don't seem fully understand how myHack works and make wrong assumptions but no point debating on this...


The bootpacks I mentioned are in a pinned thread at the very top of this D6xx section. I don't use Clover, only Chameleon/Enoch with manual installations from Yosemite and myHack for OS X versions up to Mavericks.


If you want to try Yosemite, you can use the process detailed in my El Capitan guide with the Yosemite pack + Yosemite kernel(s) instead of the EC ones.


Good luck in your endaevour.

Link to comment
Share on other sites

I was not arguing, just relating some facts, politely.

I don’t use forums to spend the time of others expressing my distress, but to learn and exchange, with respect.

If this simple attitude is normal for a user, it should be mandatory for an administrator, don’t you think?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...