Jump to content
PayPal donations: [email protected] ×

El Capitan on Inspiron 1720


Recommended Posts

Guys, I could really use help with two issues.


-  Unable to get all USB ports working. I actually noticed there are 5 USB ports, and only 3 work. I followed instructions for creating USB injector. The problem is I don't see EHC1, EHC2 device names in my DSDT (attached above). So renaming to EH01, EH02 and then linking into my Injector Kext does not work. I could of course try eliminating port count from original Apple Kext, but wanted to rule out any obvious mistakes I was making.


- As expected, I got the latest HWMonitor. Seems to work for all sensors except Battery which says 139%. I tried multiple FakeSMCs, so I don't think that's the issue. Could it be I need different ACPIBatteryManager.kext?

Link to comment
Share on other sites

  • Replies 37
  • Created
  • Last Reply

Top Posters In This Topic

Sorry Herve, trying to follow. You are saying I should also extract SSDT? And once I do that I will see names of USB devices? And then I should use those names in my Injector kext?  t


If so, would like to know best way of extracting SSDT. I had used DSDT Editor running it from my Windows Disk for the DSDT.


Also can you comment on ACPIBatteryManager.kext? Will fixing it solve my 139% issue with HWMonitor, or am I on the wrong track?

Link to comment
Share on other sites

Sorry I thought I needed to see EHC1, EHC2 as well as the device names, e.g. PRT1, PRT2, etc...before it would work.

So my USB Injector kext with EH01/02 was correct. All I did was search replace in DSDT ECH1-->EH01 and EHC2-->EH02, and now all USB ports work!


Now my incorrect Battery Percentage in HWMonitor. How do I proceed?

Link to comment
Share on other sites

@Herve. Got the latest Rehabman Battery and installed. DONE! Thank you so much. The install went quite fast once it got going. Every time I learn something new. Everything works great, and maybe I'm imagining it, but 10.11 seems to work noticeable faster than 10.10 on this machine.


I will now continue my ritual of getting SD Card to work before giving up. I've never succeeded with SD Card but maybe this time I will get lucky.



Link to comment
Share on other sites

Herve, Bronxtech, JakeLo,


Thought best to move SD Card conversation to this thread for I1720.


So first, I have 2 hard drives in this laptop. The other is running Windows. So I know my SD Card VVVV = 1180 and DDDD = 0822. However, I cannot tell the make. Seems like a generic brand. I downloaded lspci I could find but it will not install - simply quits without doing/saying anything. 


I can see the card in my IOReg (attached). First when I looked at IOReg I thought it was CRD0, because CRD seemed like "card" and its DDD was 832 and I misread it as 0822. However I do indeed see 1180,0822 in my IOReg as PCI device.


Problem is I cannot locate the SD Card in my DSDT (latest attached). Thinking maybe I can add the card info from IOReg registry and perhaps it will recognize it. I'm out of my element here.


Regarding VoodooSDHC, I have tried two different versions. Neither worked. Not sure if any of the above is required along with VoodooSDHC or VoodooSDHC by itself will do the trick. If anyone can tell me which VoodooSDHC to try, I can give it a shot.


Thanks much





Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...